Supported Platforms

This is the list of supported platforms. The versions listed are the ones on which Kapow Katalyst has been tested. This does not mean that it will not work on other versions. If in doubt whether it works on a version not listed contact Kapow Software to get more information.

IDE Platforms

Windows

Windows Server 2003 SP2, Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, Windows Vista, Windows 7, Windows 8

Linux

CentOS/Red Hat Enterprise Linux 6.x, Ubuntu 12.04 LTS

Server Platforms

Windows

Windows Server 2003 SP2, Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, Windows Vista, Windows 7, Windows 8

Linux

CentOS/Red Hat Enterprise Linux 5.6 or 6.x, Debian 7.2

Databases

Oracle*

Version 11g

IBM DB2

9.7

Microsoft SQL Server

Version 2005, 2008 and 2008 R2

Sybase*

Adaptive Server Enterprise 15.0 using the jConnect for JDBC 3.0 version 6.0.5 driver

MySQL*

Version 5.x

PostgreSQL 9.2

If you don't want to use the 'public' schema, you must set the default schema for the user account accessing PostgreSQL (ALTER USER <username> SET search_path to <schema>)

HBase

The step Store in HBase Table can be used with HBase Version 0.90.6.

APIs

Java

Java 1.5 or later. Including J2EE servers such as Oracle WebLogic 11, IBM WebSphere, and JBOSS

JMX

Java 1.6

.NET

C#, .NET Version 4.0

Management Console Portals

Tomcat

Version 5.5, 6.0 and 7.0. Minimum Java 1.7.

Other Supported Technologies

Supported browsers for Management Console and KappZone/Kapplets

Internet Explorer version 9, 10, and 11; Chrome version 31 and later; Firefox version 25 and later; Safari version 7.

* Be aware that loss of data may occur when storing data in Oracle, Sybase or MySQL. On Oracle empty string is converted to null. On Sybase empty string is converted to " " (a single space). On MySQL millisecond precision is lost when storing dates. Check ObjectKey Caveats for details.